Cannot get error-free model

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Cannot get error-free model

KonaDawg
Sorry in advance if this is just simple user error - but I understood from the tutorials that labels that are red indicate an error.  I cannot create any models without an error, so I reverted to simply trying to add a tied anchor to the sample model.  I tied it to the Performance anchor, then tried to replicate the 1-1 mapping as for the Event anchor.  I named it Ev2, named the role names identically to Event, and cannot see any difference between the Event and my Ev2 - yet Ev2 is still in red.  What am I doing wrong.

Bob

Here's a clip of the problem:
Reply | Threaded
Open this post in threaded view
|

Re: Cannot get error-free model

Chris
Hi Kona,
Is this model saved as a public model? If so, can you provide the name so we can view the entire model? That might be more helpful.

Thanks!
Reply | Threaded
Open this post in threaded view
|

Re: Cannot get error-free model

KonaDawg
OK - I saved the model as "KonaDawg-error".  All I did was add a new tied anchor named "Event2" and then tried to make it look exactly like the tied anchor named "Event".  I compared the SQL code, and everything appears to be good.

Note that my screenshot is not exactly the same as my new model as I named the anchor Ev2 in that model.
Reply | Threaded
Open this post in threaded view
|

Re: Cannot get error-free model

Chris
Hi Kona,
The solution is simple! The mnemonic EV2 is invalid. Anchor mnemonics can only be 2 characters long. Attributes can have a 3 character mnemonic, but anchors can only have 2.
If you change the mnemonic to something like EX, it resolves the naming issue. Anchor mnemonics must be unique across the whole model. The modeler also requires that the mnemonic be all upper case.

Hope this helps. Cheers!
Chris
Reply | Threaded
Open this post in threaded view
|

Re: Cannot get error-free model

KonaDawg
Thanks Chris!  That was it.  I just was unfamiliar enough with the app to pay attention to the cues that I was getting about the problem.  I think I've got a much better handle on it now and am looking forward to some modeling.

Bob
Reply | Threaded
Open this post in threaded view
|

Re: Cannot get error-free model

Chris
You're welcome! I'm glad I was able to help.